Choisir l'encapsulation

Il existe 2 types de trunk ISL et 802.1Q.

ISL 802.1Q
Cisco Proprietary Nonproprietary
Encapsulated Tagged
Protocol independent (ne dépend pas du niveau 2) Protocol dependent
Encapsulates the old frame in a new frame (26 bytes en entête et 4 bytes de crc soit 30 bytes d'overhead, la trame peut être vu comme giant) Adds a field to the frame header (insertion de 4 bytes parès l'adresse mac de destination)

Si le switch supporte 802.1q et ISL, il faut lui spécifier quelle encapsulation utiliser.

Les nouveaux switchs ne supportant que 802.1q, la commande n'existe plus.

SW(config-if)# swtichport trunk encapsulation dot1q

Choisir un mode static ou dynamic

Cisco recommande de forcer les ports en trunk, non négocié.

 SW(config-if)# switchport mode trunk

Désactiver la négociation DTP

SW(config-if)# switchport nonegotiate
Vérifier l'état DTP d'un port
SW#show dtp interface fastEthernet 0/9
DTP information for FastEthernet0/9:
  TOS/TAS/TNS:                              TRUNK/NONEGOTIATE/TRUNK
  TOT/TAT/TNT:                              802.1Q/802.1Q/802.1Q
...
Switchport Mode Interactions

Il est possible d'avoir un trunk dynamique.

SW(config-if)#switchport mode ?
  access   Set trunking mode to ACCESS unconditionally
  dynamic  Set trunking mode to dynamically negotiate access or trunk mode
  trunk    Set trunking mode to TRUNK unconditionally
SW(config-if)#switchport mode dynamic ?
  auto       Set trunking mode dynamic negotiation parameter to AUTO
  desirable  Set trunking mode dynamic negotiation parameter to DESIRABLE
Dynamic Auto Dynamic Desirable Trunk Access
Dynamic Auto Access Trunk Trunk Access
Dynamic Desirable Trunk Trunk Trunk Access
Trunk Trunk Trunk Trunk Not recommended
Access Access Access Not recommended Access

Configurer le native vlan

SW(config-if)# switchport trunk native vlan 55

Configurer un filtrage de VLAN

SW(config-if)# switchport trunk allowed vlan 11,13

Attention à la commande allowed vlan. Il faut mettre tous les vlans sur la même ligne ou spécifier add/remove pour modifier la liste existante.

Exemple, on souhaite autoriser le vlan 13 et 14 à passer dans notre trunk avec les commandes suivantes:

SW(config-if)# switchport trunk allowed vlan 13
SW(config-if)# switchport trunk allowed vlan 14

La seconde commande supprime l'information de la première et nous n'avons plus que le vlan 14 autorisé. Pour avoir 13 et 14, il faut utiliser la commande add.

SW(config-if)# switchport trunk allowed vlan 13
SW(config-if)# switchport trunk allowed vlan add 14

Vérifier la configuration du trunk

SW#sh run int fa 0/9
Building configuration...

Current configuration : 176 bytes
!
interface FastEthernet0/9
 description 1ASW1 0/9 - 1DSW1 0/1
 switchport trunk allowed vlan 11,13
 switchport mode trunk
 switchport nonegotiate
 speed 100
 duplex full
end
SW#sh interfaces fa 0/9 trunk

Port        Mode         Encapsulation  Status        Native vlan
Fa0/9         on            802.1q           trunking        1

Port        Vlans allowed on trunk
Fa0/9       1,11,13,1002-1005

Port        Vlans allowed and active in management domain
Fa0/9         1,11,13

Port        Vlans in spanning tree forwarding state and not pruned
Fa0/9       none

Remarque

Si un switch possède un trunk ISL et un trunk 802.1Q, il est possible de mapper les vlans du trunk avec les vlans du trunk 802.1Q. Un maximum de 8 correspondances est possible.